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Abstract

Time and efficiency are a matter of priority of present
day. The improper management at bus terminals and
at toll gates leads to high level of waiting time, fuel
consumption and pollution levels too. In this project
we use wireless fidelity technology. The functional
part of this project is considered to be of two parts.
First part is at bus terminals where the buses
information will be read by the WIFI Module placed
at entry and exit points of bus station. The read
information is send to the control room wirelessly
and the same information is available in the cloud for
authorized users. This functionality is new and not
implemented yet at any bus station. The second part
is at tollgate where the buses information will be read
by the WIFI Module and segregate into individual
depot buses and the same will be sending to
corresponding depot manager along with amount
payable information. This functionality is a modified
version of current existing “WIFl toll gate
collection” with the inclusion of IoT. We are
planning to place a WIFI Module for every vehicle &
each tag is equipped with information like vehicle
number, service route number, vehicle belongs to
which depot, source and destination points. WIFI
Module will be placed at the entry, exit gates of bus
terminals and toll plazas. Whenever the vehicle
enters or exits the terminals, the module reads the
information. The source and destination depots and
service number are stored in cloud the same data was
provided to the users and depot manager along with
date, entering time and exit time of vehicle. Similarly,
whenever the vehicle enters into the toll gates WIFI
module reads information from the tag. Collected
data was available in the cloud for further analysis
the same information will be sent to respective depot
manager so that they can pay the total amount
through online transaction and this information is
secured.
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I. INTRODUCTION

Time and efficiency are a matter of priority
of present day. In India over 90% of the
population, the mode of transport rely upon
public transportation. Due to this social
significance, urban bus transport is often
owned and Operated by public agencies, and
many Indian states government has their
own fleet of buses which are run under their
State Road Transport Corporation (RTC).
These corporations have proven extremely
useful in connecting villages and towns
across the country. The improper
management at bus terminals and at toll
gates leads to high level of waiting time, fuel
consumption and pollution levels too. Even
today at bus terminals, the vehicle
information is logged manually either by the
driver or by the conductor. It involves a lot
of manual effort, leads to wastage of travel
time and gives inconvenience to passengers.
Still there are many solutions available for
this problem but in very few places the work
around solutions are implemented till date.

Advantages of Vehicle Logging
Automatic  entries of  vehicle
information at bus terminals.

Reduces the manual effort.
Real — time vehicle information to
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the user.

1 Reduces the traffic congestion at
rush hours.

"1 Encourage digital transactions.

Problem Definition

The major problem identified in bus
terminals is still the manual entry of the
vehicle by the driver. Due to the manual
intervention of vehicle data logging, pretty
much inconvenience to the passengers and
also leads to fewer time delay. And in
extension long waiting time for the next stop
passengers because they don’t know the bus
arrivaltimings in accurate. And at the toll
gates, payment of toll tax through cash
mode. In affect of this, more time is wasted
in executing the process, which leads to
piling up of vehicles at toll gate.

Proposed System Feature

The above mentioned problems are solved
using a common device setup. The
components used in this system are:

Node MCU (ESP8266 — 12E)
MFRC522 (WIFI)

Mifare 1Kb Tag (WIFI Tag)
Arduino Uno R3

Wiznet W5100 (Ethernet Shield)
16 X2 LCD

REES52 (12C interface module)

I s [ O A

SYSTEM DESIGN AND
IMPLEMENTATION

Existing

There are two systems which exist currently.
One is automation of public transportation
vehicle using WIFI and ZigBee. Another
one is automated toll collection system using

RFID. In both the systems, WIFI is used.
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Fig 1: Existing system block
diagram

In the former system the information is sent
to the controller via ZigBee network. The
limitations in both the systems are, these
systems are localized systems where the
information cannot be sent to internet. This
information is stored locally where it can’t
be accessed by any other person.

Limitations:
1 Using ZigBee network which may be

interfered with high frequency
radiation leads to data loss.

1 Using of GSM network which is
unreliable  based on  network
availability.

1 WIFI tag used need acceptance from
RTO and other  government
authorities.

1 Security issues related to payment
and data available for authorized
users

Proposed

Here in this system, the above mentioned
systems are combined and made as a single
system. Both the functionalities are achieved
using same system setup. In this project we
used loT and WIFI technology. The
functional part of this project is considered
to be of two parts. First part is at bus
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terminals where the buses information will
be read by the WIFI modules placed at entry
and exit points of bus station. The read
information is send to the control room
wirelessly and the same information is
available in the cloud for authorized users.
This  functionality is new and not
implemented yet at any bus station. The
second part is at tollgate where the buses
information will be read by the WIFI and
segregate into individual depot buses and the
same will be sending to corresponding depot
manager along with amount payable
information. This functionality is a modified
version of current existing “WIFI toll gate
collection” with the inclusion of loT.

We are planning to place a WIFI tag for
every vehicle & each tag is equipped with
information like vehicle number, service
route number, vehicle belongs to which
depot, source and destination points. WIFI
modules will be placed at the entry, exit
gates of bus terminals and toll plazas.
Whenever the SRTC vehicle enters or exits
the terminals, the module reads the
information. The source and destination
depots and service number are stored in
cloud the same data was provided to the
users and depot manager along with date,
is read by WIFI module and sends the
information with date and time to the
control room again acts as a client.

Similarly, whenever the vehicle enters
into the toll gates WIFI module reads
information from the tag. Collected data
was available in the cloud for further
analysis the same information will be
sent to respective depot manager so that
they can pay the total amount through
online transaction and this information is
secured.

entering time and exiting vehicle time.

Fig 2: System architecture at bus
terminal

At bus terminals:

Mifare 1Kb tags written with predefined
vehicle information like Service No., Source
and Destination points, Vehicle No. and
Depot Name are attached to the buses.
Whenever these buses are entering into the
bus terminals, WIFI module which is placed
at entry gate will read the bus information
which is stored in tags and sends this
information to the control room using Wi-Fi.
The WIFI module is interfaced to Node
MCU (ESP8266 — 112E) having an inbuilt
Wi-Fi module acts as server. The bus
information which is read from the tags
along with date and time will be sending to
control room which acts as client. By using
the same hardware setup at exit gate when
the bus leaves the bus terminal, the bus
information

ool O

v

Fig 3: System architecture at toll gate

At Toll gates:

Whenever any bus come closer to the toll
plaza, WIFI module is placed on the roof
of the plaza where it reads the WIFI tag.
Then this information is stored in the
local database or on the SD card. This
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information is sent via Ethernet cable to
the local system which acts as client.
Thereafter it will be segregated in terms
of depot names and sent across internet to
the concerned depot managers. This
information is secured in internet. Along
with this the information is displayed on
LCD.

The bus information which is read
from the tags along with date and time
will be sending to control room which
acts as client. By using the same
hardware setup at exit gate when the bus
leaves the bus terminal, the bus
information is read by WIFI module and
sends the information with date and time
to the control room again acts as a client.

SOFTWARE DESIGN

Arduino IDE corner of the window
displays the configured board and serial
port. The toolbar buttons allow you to
verify and upload programs, create, open,
and save sketches, and open the serial
monitor.

The Arduino Integrated Development
Environment - or Arduino Software
(IDE). It contains a text editor for writing
code, a message area, a text console, a
toolbar with buttons for common
functions and a series of menus. For
communicating and for uploading the
programs IDE is connected through an
USB cable to the Arduino and Genuino
hardware. The code or program written
for Arduino IDE is called SKETCH.
These sketches are written in the text
editor and are saved with the file
extension (.ino). We can even do the
modification of the sketch by

cutting/pasting and for
searching/replacing text in the editor
window. In the message area, it provides
feedback while saving and exporting and
also displays errors and warnings. The
console displays text output by the
Arduino  Software (IDE), including
complete error messages and other
information. The bottom right hand
corner of the window displays the
configured board and serial port. The
toolbar buttons allow you to verify and
upload programs, create, open, and save
sketches, and open the serial monitor.

Installing the ESP8266 Board

To install the ESP8266 board in your

Arduino IDE, follow these next

instructions:

1) Open the preferences window from the

Arduino IDE. Go to File > Preferences

2)Enter

http://arduino.esp8266.com/stable/packa

ge_esp8266com _i ndex.json into

Additional Board Manager URLSs field

and CLICK the OK button

3) Open boards manager. Go to Tools >
Board > Boards

Manager...

4) Scroll down, select the ESP8266

board menu and install “esp8266

platform”

5) Choose your ESP8266 board from

Tools > Board > Generic ESP8266

Module

6)finally, re-open your Arduino IDE

Implementation Setup
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Fig 4: Vehicles at entry and exit gates of
bus terminal

Figure 4 explains the bus entry and exit
at the bus terminal. The process flow of
the system is explained in the flow chart.
Initially bus enters or exits the terminal
WIFI module reads the information from
WIFI tag which is attached to the bus.
The read information is sent to the
control room using Wi — Fi. Then the
filtered information is sent to the next bus
terminal as well as to the authorised user.
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Fig 5: Functional flow chart at bus
terminal

At the toll gate, the WIFI module reads
the information from tag which is
attached to bus. The read information is
stored in the local database connected to
a system using Ethernet cable. Then the
information is sent to bus depot along
with the billing details. This improves the
transparency in  governance  and

encourages digital transactions.

Fig 7: Functional flow
chart at bus terminal

RESULTS

In the figure above shows the complete
project setup, where you can observe the
WIFI modules are installed at entry and
exit gates of the bus terminal and at the
toll gate.

Fig 8: Full hardware setup of
the project

The read information is displayed on the
serial terminal for internal debugging

Anveshana’s International Journal of Research in Engineering and Applied Sciences

EMAILID:anveshanaindia@amail.com,WEBSITE:www.anveshanaindia.com



mailto:anveshanaindia@gmail.com
http://www.anveshanaindia.com/

AIJREAS VOLUME 3, ISSUE 5 (2018, MAY)

(1SSN-2455-6300)ONLINE

Anveshana’s International Journal of Research in Engineering and Applied Sciences

purpose and also displayed on the LCD
for better user experience.

Bus Data

iw Bt e oyt e} N

Fig 9: Bus Data display on LCD screen

Conclusion

In conclusion, we hope that this project
can successful be acceptable and
complete soon as possible and follow the
schedule. By the research that has been
done it is good enough for improvement
all part this project. Real — time vehicle
logging is used to avoid the human
intervention in recording the vehicle
information.

Future work

At present we are sending the
information to the local database,
whereas you can extend this by sending it
to cloud and store as much data as you
can. And in future perspective the data
can be used for analytics.
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